Page 1 of 1

Problem with new(ish) esc

PostPosted: Thu Nov 26, 2015 1:59 pm
by jamest
Ok guys, anyone there good with electrics?
My M03 has a Core RC Rx, a savox steering servo (1258TG), a silver can 540 motor and a Tamiya teubk104 esc with a voltage regulator (6v, 5A) for the Rx. It works OK.
I tried swapping the esc for an xt12, which has a built on BEC. Now when I apply just the throttle it's ok. However if I apply some steering, the servo freezes for anything up to three secs and then the esc will freeze for up to20secs with flashing red lights suggesting no signal to the Rx. Green light on the Rx also goes out for a sec or two. Eventually the esc comes back online before reverting back to this annoying habit. I've tried replacing the servo for a standard Acoms one, but the problem remains. Anyone any ideas what could be going on?
Pete

Re: Problem with new(ish) esc

PostPosted: Sun Dec 20, 2015 10:35 pm
by Bosscat
Sounds like the BEC on your replacement speedo is not supplying enough current. Your previous regulator is 5 amp you need to check how much current your speedo Bec provides.