Problem with new(ish) esc

General chat

Problem with new(ish) esc

Postby jamest » Thu Nov 26, 2015 1:59 pm

Ok guys, anyone there good with electrics?
My M03 has a Core RC Rx, a savox steering servo (1258TG), a silver can 540 motor and a Tamiya teubk104 esc with a voltage regulator (6v, 5A) for the Rx. It works OK.
I tried swapping the esc for an xt12, which has a built on BEC. Now when I apply just the throttle it's ok. However if I apply some steering, the servo freezes for anything up to three secs and then the esc will freeze for up to20secs with flashing red lights suggesting no signal to the Rx. Green light on the Rx also goes out for a sec or two. Eventually the esc comes back online before reverting back to this annoying habit. I've tried replacing the servo for a standard Acoms one, but the problem remains. Anyone any ideas what could be going on?
If at first you don't suceed, try a couple more times then give up; there's no use in making a complete fool of yourself!
Posts: 65
Joined: Sat Feb 12, 2011 9:29 pm
Location: East Malling.
Car: M-03M
Motor: Tamiya Silver Can
Speedo: Eastbourne thingy
Cells: Lipo 3250mAh

Re: Problem with new(ish) esc

Postby Bosscat » Sun Dec 20, 2015 10:35 pm

Sounds like the BEC on your replacement speedo is not supplying enough current. Your previous regulator is 5 amp you need to check how much current your speedo Bec provides.
Posts: 95
Joined: Tue Oct 14, 2008 7:14 pm
Location: Kent
Car: Zen Racing
Motor: Thunder 10.5
Speedo: Hobbywing
Cells: 1s Lipo

Return to Public Chat

Who is online

Users browsing this forum: No registered users and 1 guest